SQLite3-Ruby Gem Version Issues on Red Hat Linux and CentOS

So you are attempting to follow earlier instructions on installing SQLite3 to use with Ruby on Red Hat Enterprise Linux (aka RHEL) or CentOS 5 and you get the following error:

gem install sqlite3-ruby
ERROR:  Error installing sqlite3-ruby:
sqlite3-ruby requires Ruby version > 1.8.5


Don’t worry, you are not alone.  What has happened is that the SQLite3-ruby Gem has been updated past the point supported by the version of Ruby included with Red Hat and CentOS (this should apply to Oracle Linux as well but has not been tested by me.)  What we need to do is simply to specify the exact version of SQLite3 that we need.  So to install:

gem install sqlite3-ruby --version '= 1.2.4'

And now you should install without any problem.  This is a followup post to the original how-to on Installing ruby-sqlite3 on Red Hat or CentOS Linux which I posted last year.  The addition was necessary because of the change to the available gems and a complete lack of online resources mentioning this error.

3 thoughts on “SQLite3-Ruby Gem Version Issues on Red Hat Linux and CentOS”

Leave a Reply